Modme

New Modme platform coming soon!
Error with zombie spawns in zones
Viewed 218 time(s)
Topic created on 1496975807
Original post
Modme User
0 wins

My map is seperated into 5 areas. Each area is only reachable through a jump pad, but when you use the jump pad, zombies cant find you if you arent in the first zone. 

As soon as i go back to the start zone they can follow me, but not in others. Another issue is that they spawn in the wrong zones. How can I make it so that they only spawn in the players zone??

Any help is appreciated, this thing is the only thing delaying this map!

Reply #1 on 1497523594
Modme User
26 wins

First you need to connect your islands with a monster_clip or normal clip so the zombies can walk over to the other islands (even if you're using teleporters for them). You also need to add at least 1 pathnode from the entity browser to each island.


I've tried nothing and I'm out of ideas.
My creations:
DE gate trap
Debug (on/off)
Jukebox
Gum Anti-cheat
Kino box locator
Panzer Soldat - PM if your map is worth it
Reply #2 on 1497816395
Modme User
0 wins

mathfag

First you need to connect your islands with a monster_clip or normal clip so the zombies can walk over to the other islands (even if you're using teleporters for them). You also need to add at least 1 pathnode from the entity browser to each island.

 Thanks for the tips. The path nodes did in fact work, but the islands are too far away for them to walk too, it would take forever. Is there a way to make them despawn when in a zone without a player?

Reply #3 on 1497828260
Modme User
10 wins

you could just make your zombies teleport from 1 to the other so they dont have to walk the distance ;)

 

https://www.youtube.com/watch?v=_86tluzY5E8